<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>

<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=0.9, minimum-scale=0.9">

<title>Kid Cudi: Passion, Pain &amp; Demon Slaying - My Met Media</title>

<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://mymetmedia.com/xmlrpc.php" />


<!-- This site is optimized with the Yoast SEO plugin v4.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//hosted.muses.org' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="My Met Media &raquo; Feed" href="http://mymetmedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="My Met Media &raquo; Comments Feed" href="http://mymetmedia.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="My Met Media &raquo; Kid Cudi: Passion, Pain &#038; Demon Slaying Comments Feed" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/mymetmedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=99e1b4f6d34c45e6257354c89fd35708"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='scap.flashblock-css'  href='http://mymetmedia.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='http://mymetmedia.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='flick-css'  href='http://mymetmedia.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='http://mymetmedia.com/?mcsf_action=main_css&#038;ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='http://mymetmedia.com/wp-content/plugins/mailchimp/css/ie.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://mymetmedia.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.1' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='social-logos-css'  href='http://mymetmedia.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://mymetmedia.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='adsanity-default-css-css'  href='http://mymetmedia.com/wp-content/plugins/adsanity-a99JON/css/widget-default.css?ver=1.0.9.1' type='text/css' media='screen' />
<link rel='stylesheet' id='bootstrap-css'  href='http://mymetmedia.com/wp-content/themes/_stylebook/framework/bootstrap/css/bootstrap.min.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-responsive-css'  href='http://mymetmedia.com/wp-content/themes/_stylebook/framework/bootstrap/css/bootstrap-responsive.min.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://mymetmedia.com/wp-content/themes/_stylebook/framework/font-awesome/css/font-awesome.min.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='gabfire-style-css'  href='http://mymetmedia.com/wp-content/themes/mymetmedia/style.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<link rel='stylesheet' id='custom-style-css'  href='http://mymetmedia.com/wp-content/themes/mymetmedia/custom.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<script type='text/javascript' src='https://hosted.muses.org/mrp.js?ver=1.6'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/mailchimp//js/scrollTo.js?ver=1.5.7'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/jquery/jquery.form.min.js?ver=3.37.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"http:\/\/mymetmedia.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/mailchimp//js/mailchimp.js?ver=1.5.7'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.1'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var userSettings = {"url":"\/","uid":"0","time":"1489699085","secure":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/utils.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/jquery.cycle2.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/jquery.easing.1.3.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/jquery.contentcarousel.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/framework/bootstrap/js/bootstrap.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/flowplayer/flowplayer.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/responsive-menu.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/jquery.tools.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/_stylebook/inc/js/slides.min.jquery.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<link rel='https://api.w.org/' href='http://mymetmedia.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://mymetmedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://mymetmedia.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://mymetmedia.com/?p=63516' />
<link rel="alternate" type="application/json+oembed" href="http://mymetmedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://mymetmedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F&#038;format=xml" />
<script type="text/javascript" src="http://mymetmedia.com/wp-content/plugins/audio-player/assets/audio-player.js?ver=2.0.4.6"></script>
<script type="text/javascript">AudioPlayer.setup("http://mymetmedia.com/wp-content/plugins/audio-player/assets/player.swf?ver=2.0.4.6", {width:"290",animation:"no",encode:"yes",initialvolume:"60",remaining:"no",noinfo:"no",buffer:"5",checkpolicy:"no",rtl:"no",bg:"2f2f2f",text:"dedbd1",leftbg:"2f2f2f",lefticon:"dedbd1",volslider:"666666",voltrack:"FFFFFF",rightbg:"2f2f2f",rightbghover:"999999",righticon:"dedbd1",righticonhover:"FFFFFF",track:"666666",loader:"0040ff",border:"CCCCCC",tracker:"0e2df2",skip:"666666",pagebg:"FFFFFF",transparentpagebg:"yes"});</script>
<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<!-- call Shout Stream Javascript in HEAD -->
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/swfobject.js?ver=2.2-20120417'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/shout-stream/ss_popup.js?ver=1.0'></script>
<!-- done Shout Stream Javascript in HEAD -->

<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-54042145-1', 'auto');
  ga('send', 'pageview');

</script>
<link rel="shortcut icon" href="http://mymetmedia.com/wp-content/uploads/2014/08/Met_favicon.png"/>
<!-- Custom Styling -->
<style type="text/css">
.column-1, .column-2, .column-3 {
    width: auto !important;
}
.site-header .widget{margin-bottom:0px;}</style>
	<script type='text/javascript'>
	<!--	
	(function($){
		$.fn.jfontsize = function(opcoes) {
			var $this=$(this);
			var defaults = {
				btnMinusClasseId: '.fontSizeMinus',
				btnPlusClasseId: '.fontSizePlus',
				btnMinusMaxHits: 5,
				btnPlusMaxHits: 5,
				sizeChange: 1
			};

			if(($.isArray(opcoes))||(!opcoes)){
				opcoes = $.extend(defaults, opcoes);
			} else {
				defaults.sizeChange = opcoes;
				opcoes = defaults;
			}

			var limite=new Array();
			var fontsize_padrao=new Array();

			$(this).each(function(i){
				limite[i]=0;
				fontsize_padrao[i];
			})

			$('.fontSizeMinus, .fontSizePlus').removeAttr('href');
			$('.fontSizeMinus, .fontSizePlus').css('cursor', 'pointer');

			/* A- */
			$('.fontSizeMinus').click(function(){
				$this.each(function(i){
					if (limite[i]>(-(opcoes.btnMinusMaxHits))){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize-(opcoes.sizeChange);
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]--;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})

			/* A+ */
			$('.fontSizePlus').click(function(){
				$this.each(function(i){
					if (limite[i]<opcoes.btnPlusMaxHits){
						fontsize_padrao[i]=$(this).css('font-size');
						fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
						fontsize=$(this).css('font-size');
						fontsize=parseInt(fontsize.replace('px', ''));
						fontsize=fontsize+opcoes.sizeChange;
						fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
						limite[i]++;
						$(this).css('font-size', fontsize+'px');
					}
				})
			})
		};
	})(jQuery);	
	(function($) {
		$.noConflict();
		$(document).ready(function() {
			$(".children").parent("li").addClass("has-child-menu");
			$(".sub-menu").parent("li").addClass("has-child-menu");
			$(".drop").parent("li").addClass("has-child-menu");
			
			$('.fadeimage').hover(
				function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
				function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
			);
			
			$('.mastheadnav li ul').hide().removeClass('fallback');
			$('.mastheadnav > li').hover(
				function () {
					$('ul', this).stop().slideDown(250);
				},
				function () {
					$('ul', this).stop().slideUp(250);
				}
			);			
			
			$('.mainnav li ul').hide().removeClass('fallback');
			$('.mainnav > li').hover(
				function () {
					$('ul', this).stop().slideDown(250);
				},
				function () {
					$('ul', this).stop().slideUp(250);
				}
			);

			$('.secondnav li ul').hide().removeClass('fallback');
			$('.secondnav > li').hover(
				function () {
					$('ul', this).stop().slideDown(250);
				},
				function () {
					$('ul', this).stop().slideUp(250);
				}
			);	
			
			$('#tabs-left').tab();
			$('#tabs > li > a').hover( function(){$(this).tab('show');});

			$('.entry p').jfontsize();
			
			
				$('#bootstartCarousel').carousel({
				interval: 10000,
				pause : 'hover'
				});
							
			$('.mediagallery').contentcarousel({
				// speed for the sliding animation
				sliderSpeed     : 500,
				// easing for the sliding animation
				sliderEasing    : 'easeOutExpo',
				// speed for the item animation (open / close)
				itemSpeed       : 500,
				// easing for the item animation (open / close)
				itemEasing      : 'easeOutExpo',
				// number of items to scroll at a time
				scroll          : 1
			});	
						
			$('a[href="#top"]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });		
			// Responsive Menu (TinyNav)
			$(".menu").tinyNav({
				active: 'current_page_item', // Set the "active" class for default menu
				label: ''
			});
			$(".tinynav").selectbox();
			$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
			$('.tooltip-link').tooltip({ placement: 'right'});

		});
	})(jQuery);
	// -->
	</script>
	
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://mymetmedia.com/wp-content/uploads/2014/08/Website-Background.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
<meta name="generator" content="Powered by Slider Revolution 5.1 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Kid Cudi: Passion, Pain &#038; Demon Slaying" />
<meta property="og:url" content="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/" />
<meta property="og:description" content="As a die-hard Kid Cudi fan, I have always admired how unique and distinguished his style can be. His past albums have shown his audience how he can easily transform himself musically in any way he …" />
<meta property="article:published_time" content="2017-03-11T20:00:04+00:00" />
<meta property="article:modified_time" content="2017-03-12T03:08:22+00:00" />
<meta property="og:site_name" content="My Met Media" />
<meta property="og:image" content="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg" />
<meta property="og:image:width" content="4890" />
<meta property="og:image:height" content="3260" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
		<!-- Generated by Revive Adserver 3.0.5 -->
		<script type='text/javascript' src='http://mymetmedia.com/ads/www/delivery/spcjs.php?id=1&amp;target=_blank'></script>
					<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.*/
.column-1,
.column-2,
.column-3 {
	width: 240px;
	display: inline-block;
}

nav .mastheadnav li a {
	font: 16px arial, 'Open Sans', arial, sans-serif;
}

.icon-facebook {
	background: #3b5998 !important;
}

.icon-twitter {
	background: #4099ff !important;
}

.icon-rss {
	background: #ff6633 !important;
}

.grofile-thumbnail {
	float: left;
	margin: 0 10px 10px 0;
	max-width: 100px;
	width: 100%;
}

.widget-grofile h4 {
	display: none;
	margin: 1em 0 .5em;
}

header .sitelogo {
	max-width: 400px;
}

header .sitelogo img {
	width: 100%;
}

.headerbanner {
	max-width: 728px;
}

.headerbanner img {
	width: 100%;
}

#gform_4 input {
	height: auto;
}

@media (min-width: 321px) and (max-width: 979px) {
	.headerbanner {
		display: block;
	}
}			</style>
		
<!--[if IE 7]>
  <![endif]-->

<!-- HTML5 shim, for IE6-8 support of HTML5 elements -->
<!--[if lt IE 9]>
	<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

</head>

<body class="post-template-default single single-post postid-63516 single-format-standard custom-background">

<div class="pagetools">
				<a class="pagetool_item tooltip-link" href="http://mymetmedia.com/gallery-2/hockey-msu-denver/" title="Prev post: Hockey at MSU Denver"><i class="icon-arrow-left"></i></a>
					<a class="pagetool_item tooltip-link" href="http://mymetmedia.com/the-metropolitan/theatre-corner-nance-work-art/" title="Next post: Theatre Corner: The Nance, a work of art"><i class="icon-arrow-right"></i></a>
		
		<a class="pagetool_item tooltip-link" href="http://mymetmedia.com" title="Go to homepage"><i class="icon-home"></i></a>	</div>


<div class="container">
		<div class="row">
			<div class="span12">
				<div class="sitebody">
					<header class="site-header">

						<div class="masthead">
							<nav class="masthead-navigation">
								<ul class="mastheadnav menu">
									<li class="firstli"><a href="http://mymetmedia.com/" title="The Student Voice of MSU Denver">Home</a></li>
									<li id="menu-item-39892" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-39892"><a href="http://mymetmedia.com/about-2/">About</a>
<ul class="sub-menu">
	<li id="menu-item-47889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47889"><a href="http://mymetmedia.com/meet-our-staff/">Meet Our Staff</a></li>
</ul>
</li>
<li id="menu-item-39895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39895"><a href="http://mymetmedia.com/jobs/">Work @ Met Media</a></li>
<li id="menu-item-39893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-39893"><a href="http://mymetmedia.com/advertise/">Advertise</a>
<ul class="sub-menu">
	<li id="menu-item-48692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48692"><a href="http://mymetmedia.com/advertise/accept-payment/">Accept Payment</a></li>
</ul>
</li>
<li id="menu-item-39894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39894"><a href="http://mymetmedia.com/contact/">Contact</a></li>
								</ul>
							</nav>
							<div class="span2" style="margin-left: 16px;width: 205px;margin-top:2px;"><form action="" class="searchform" style="margin: 0px;" method="get">
							<fieldset>
							<input type="text" onblur="if(this.value=='')this.value=this.defaultValue;" onfocus="if(this.value==this.defaultValue)this.value='';" value="Search in site..." name="s" id="s"  style="width: 146px; height: 13px; margin-bottom: 0px;">
							<input type="submit" style="height: 25px;font-size: 12px;" value="GO">
							<input type="image" value="" alt="Search in site..." src="http://mymetmedia.com/wp-content/themes/_stylebook/framework/images/clear.png" class="submitsearch"> 
						</fieldset>
						</form></div>
							<div class="social_header pull-right">
																			<a href="http://www.facebook.com/metmedia" title="Facebook" rel="nofollow">
											<i class="icon-facebook pull-left"></i>
										</a>
									
																			<a href="https://twitter.com/MyMetMedia" title="Twitter" rel="nofollow">
											<i class="icon-twitter pull-left"></i>
										</a>
									
									
									
																		
																		
									
																				

									<a href="http://mymetmedia.com/feed/" title="Site feed" rel="nofollow">
										<i class="icon-rss pull-left"></i>
									</a>
							</div><!-- social_header-->	
		
														<div class="clearfix"></div>
						</div><!-- /masthead -->					
					
						<div class="header_2ndrow">
							<div class="sitelogo pull-left" style="padding:0px 0px 15px 0px;">	
																	<h1>
										<a href="http://mymetmedia.com/" title="The Student Voice of MSU Denver">
											<img src="http://mymetmedia.com/wp-content/uploads/2015/08/Web-Banner1.png" alt="My Met Media" title="My Met Media"/>
										</a>
									</h1>
															</div><!-- .logo -->					

							                <div class="pull-right headerbanner">
                  <section id="adsanity-random-8" class="widget adsanity-random"><div class="widgetinner"><div id="ad-52068" class="ad-728x90 column-1">
			<a rel="nofollow" href="http://mymetmedia.com/ads/top-header-leaderboard-regency/" target="_blank"><img width="728" height="90" src="http://mymetmedia.com/wp-content/uploads/2016/02/Regency.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="http://mymetmedia.com/wp-content/uploads/2016/02/Regency.jpg 728w, http://mymetmedia.com/wp-content/uploads/2016/02/Regency-620x77.jpg 620w" sizes="(max-width: 728px) 100vw, 728px" data-attachment-id="52091" data-permalink="http://mymetmedia.com/ads/top-header-leaderboard-regency/attachment/regency/" data-orig-file="http://mymetmedia.com/wp-content/uploads/2016/02/Regency.jpg" data-orig-size="728,90" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Regency" data-image-description="" data-medium-file="http://mymetmedia.com/wp-content/uploads/2016/02/Regency-620x77.jpg" data-large-file="http://mymetmedia.com/wp-content/uploads/2016/02/Regency.jpg" /></a>
	</div><div class="clear clearfix clearboth"></div></div></section>
                </div>
                            
						  <div class="clearfix"></div>
						</div>
								
						<div class="nav_date pull-left">
							<script type="text/javascript">
								<!--
								var mydate=new Date()
								var day=mydate.getDay()
								var month=mydate.getMonth()
								var daym=mydate.getDate()
								if (daym<10)
								daym="0"+daym
								var montharray=new Array("Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec")
								document.write("<span class='gabfire_day'>"+daym+"</span><span class='gabfire_month'>"+montharray[month]+"</span>")
								// -->
							</script>
						</div><!-- nav_date -->
						
						<nav class="main-navigation pull-left">
							<ul class="mainnav menu pull-right">
								<li class="first"><a href="http://mymetmedia.com/" title="The Student Voice of MSU Denver">Home</a></li>
								<li id="menu-item-38640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38640"><a href="http://mymetmedia.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-40378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40378"><a href="http://mymetmedia.com/category/news/special-sections/">Special Reports</a></li>
</ul>
</li>
<li id="menu-item-38642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38642"><a href="http://mymetmedia.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-40379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40379"><a href="http://mymetmedia.com/category/sports/baseball/">Baseball</a></li>
	<li id="menu-item-40380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40380"><a href="http://mymetmedia.com/category/sports/basketball/">Basketball</a></li>
	<li id="menu-item-40383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-40383"><a href="http://mymetmedia.com/category/sports/club-sports/">Club Sports</a>
	<ul class="sub-menu">
		<li id="menu-item-40385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40385"><a href="http://mymetmedia.com/category/sports/golf-sports/">Golf</a></li>
		<li id="menu-item-40384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40384"><a href="http://mymetmedia.com/category/sports/hockey/">Hockey</a></li>
	</ul>
</li>
	<li id="menu-item-40381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40381"><a href="http://mymetmedia.com/category/sports/cross-country/">Cross Country</a></li>
	<li id="menu-item-40386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40386"><a href="http://mymetmedia.com/category/sports/football-sports/">Football</a></li>
	<li id="menu-item-40382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40382"><a href="http://mymetmedia.com/category/sports/lacrosse-sports/">Lacrosse</a></li>
	<li id="menu-item-40170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40170"><a href="http://mymetmedia.com/category/sports/soccer-sports/">Soccer</a></li>
	<li id="menu-item-40171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40171"><a href="http://mymetmedia.com/category/sports/softball/">Softball</a></li>
	<li id="menu-item-40173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40173"><a href="http://mymetmedia.com/category/sports/swimming-sports/">Swimming</a></li>
	<li id="menu-item-40174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40174"><a href="http://mymetmedia.com/category/sports/tennis-sports/">Tennis</a></li>
	<li id="menu-item-40175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40175"><a href="http://mymetmedia.com/category/sports/track/">Track</a></li>
	<li id="menu-item-40176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40176"><a href="http://mymetmedia.com/category/sports/volleyball/">Volleyball</a></li>
</ul>
</li>
<li id="menu-item-38641" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38641"><a href="http://mymetmedia.com/category/the-metropolitan/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-40360" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-40360"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/">Entertainment</a></li>
	<li id="menu-item-40362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40362"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/food-and-dining/">Food and Dining</a></li>
	<li id="menu-item-40363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40363"><a href="http://mymetmedia.com/category/the-metropolitan/features/health-features/">Health</a></li>
	<li id="menu-item-40364" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40364"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/food-and-dining/">Food and Dining</a></li>
	<li id="menu-item-40365" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40365"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/music/">Music</a></li>
	<li id="menu-item-40370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-40370"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/reviews/">Reviews</a>
	<ul class="sub-menu">
		<li id="menu-item-40371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40371"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/reviews/books/">Books</a></li>
		<li id="menu-item-40373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40373"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/movies/">Movies</a></li>
		<li id="menu-item-40375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40375"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/reviews/theater/">Theater</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-38643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38643"><a href="http://mymetmedia.com/category/the-metropolitan/opinion/">Op-Eds</a></li>
<li id="menu-item-38649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-38649"><a href="http://mymetmedia.com/category/mm/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-40377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40377"><a href="http://mymetmedia.com/category/mm/photos/">Photos</a></li>
</ul>
</li>
<li id="menu-item-62332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62332"><a href="http://mymetmedia.com/listen/">LISTEN TO MET RADIO</a></li>
					
							</ul>
						</nav>

						<nav class="second-navigation menu pull-left">
							<ul class="secondnav pull-right">
								<li id="menu-item-42333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42333"><a href="http://mymetmedia.com/category/the-metropolitan/">The Metropolitan</a>
<ul class="sub-menu">
	<li id="menu-item-42426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42426"><a href="http://mymetmedia.com/category/news/">News</a>
	<ul class="sub-menu">
		<li id="menu-item-42420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42420"><a href="http://mymetmedia.com/category/news/campus-news/">Campus News</a></li>
		<li id="menu-item-42421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42421"><a href="http://mymetmedia.com/category/news/denver-news/">Denver News</a></li>
		<li id="menu-item-42427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42427"><a href="http://mymetmedia.com/category/news/national-news/">National News</a></li>
		<li id="menu-item-42428" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42428"><a href="http://mymetmedia.com/category/news/special-sections/">Special Reports</a></li>
	</ul>
</li>
	<li id="menu-item-42429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42429"><a href="http://mymetmedia.com/category/the-metropolitan/opinion/">Op-Eds</a></li>
	<li id="menu-item-42460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42460"><a href="http://mymetmedia.com/category/sports/">Sports</a>
	<ul class="sub-menu">
		<li id="menu-item-42453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42453"><a href="http://mymetmedia.com/category/sports/basketball/">Basketball</a></li>
		<li id="menu-item-42463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42463"><a href="http://mymetmedia.com/category/sports/sports-columns/">Sports Columns</a></li>
		<li id="menu-item-42452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42452"><a href="http://mymetmedia.com/category/sports/baseball/">Baseball</a></li>
		<li id="menu-item-42466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42466"><a href="http://mymetmedia.com/category/sports/track/">Track</a></li>
		<li id="menu-item-42462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42462"><a href="http://mymetmedia.com/category/sports/softball/">Softball</a></li>
		<li id="menu-item-42455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42455"><a href="http://mymetmedia.com/category/sports/cross-country/">Cross Country</a></li>
		<li id="menu-item-42461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42461"><a href="http://mymetmedia.com/category/sports/soccer-sports/">Soccer</a></li>
		<li id="menu-item-42454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42454"><a href="http://mymetmedia.com/category/sports/club-sports/">Club Sports</a>
		<ul class="sub-menu">
			<li id="menu-item-42457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42457"><a href="http://mymetmedia.com/category/sports/golf-sports/">Golf</a></li>
			<li id="menu-item-42458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42458"><a href="http://mymetmedia.com/category/sports/hockey/">Hockey</a></li>
		</ul>
</li>
		<li id="menu-item-42465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42465"><a href="http://mymetmedia.com/category/sports/tennis-sports/">Tennis</a></li>
		<li id="menu-item-42467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42467"><a href="http://mymetmedia.com/category/sports/volleyball/">Volleyball</a></li>
		<li id="menu-item-42456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42456"><a href="http://mymetmedia.com/category/sports/football-sports/">Football</a></li>
		<li id="menu-item-42459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42459"><a href="http://mymetmedia.com/category/sports/lacrosse-sports/">Lacrosse</a></li>
		<li id="menu-item-42464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42464"><a href="http://mymetmedia.com/category/sports/swimming-sports/">Swimming</a></li>
	</ul>
</li>
	<li id="menu-item-42424" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42424"><a href="http://mymetmedia.com/category/the-metropolitan/features/">Features</a></li>
	<li id="menu-item-42422" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-42422"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/">Entertainment</a>
	<ul class="sub-menu">
		<li id="menu-item-42416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42416"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/campus-events/">Campus Events</a></li>
		<li id="menu-item-42423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42423"><a href="http://mymetmedia.com/category/the-metropolitan/event/">Events</a></li>
		<li id="menu-item-42469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42469"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/reviews/">Reviews</a></li>
		<li id="menu-item-42415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42415"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/art-features-2/">Art &#038; Culture</a></li>
		<li id="menu-item-42417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42417"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/food-and-dining/">Food and Dining</a></li>
		<li id="menu-item-42438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42438"><a href="http://mymetmedia.com/category/the-metropolitan/entertainment/nightlife-entertainment/">Nightlife</a></li>
	</ul>
</li>
	<li id="menu-item-53332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53332"><a href="http://mymetmedia.com/category/metvistazo">Met Vistazo</a></li>
	<li id="menu-item-42574" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42574"><a href="http://mymetmedia.com/category/the-metropolitan/audiofiles/">Audio</a></li>
	<li id="menu-item-42337" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42337"><a href="http://mymetmedia.com/themetropolitan/find-copy/">Find a Copy</a></li>
</ul>
</li>
<li id="menu-item-42323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42323"><a href="http://mymetmedia.com/category/metradio/">MET Radio</a>
<ul class="sub-menu">
	<li id="menu-item-41164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41164"><a href="http://mymetmedia.com/listen">Listen Now!</a></li>
	<li id="menu-item-41470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41470"><a href="http://mymetmedia.com/kmetradioshows/">Shows</a>
	<ul class="sub-menu">
		<li id="menu-item-62744" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62744"><a href="http://mymetmedia.com/category/kmetradio/alikaylive/">Ali Kay Live!</a></li>
		<li id="menu-item-56815" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56815"><a href="http://mymetmedia.com/category/kmetradio/baseball-power-hour/">Baseball Power Hour</a></li>
		<li id="menu-item-62745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62745"><a href="http://mymetmedia.com/category/kmetradio/blackexcellence/">Black Excellence</a></li>
		<li id="menu-item-50792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50792"><a href="http://mymetmedia.com/deepfrequenciez/">Deep Frequenciez Mixdown</a></li>
		<li id="menu-item-58564" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58564"><a href="http://mymetmedia.com/category/kmetradio/studio313bdime/">DIME</a></li>
		<li id="menu-item-62746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62746"><a href="http://mymetmedia.com/category/kmetradio/folkfriday/">Folk Friday</a></li>
		<li id="menu-item-62775" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62775"><a href="http://mymetmedia.com/category/kmetradio/girlfighttalk/">Girl Fight Talk</a></li>
		<li id="menu-item-44096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44096"><a href="http://mymetmedia.com/kmetsportsshow">Met Sports Show</a></li>
		<li id="menu-item-62686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62686"><a href="http://mymetmedia.com/category/milehighmic/">Mile High Mic</a></li>
		<li id="menu-item-62776" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62776"><a href="http://mymetmedia.com/category/kmetradio/motownmonday/">Motown Monday</a></li>
		<li id="menu-item-45252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-45252"><a href="http://mymetmedia.com/playingwithperspective">Playing With Perspective</a></li>
		<li id="menu-item-62774" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62774"><a href="http://mymetmedia.com/category/kmetradio/politically-direct/">Politically Direct</a></li>
		<li id="menu-item-52067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52067"><a href="http://mymetmedia.com/popscds">POP&#8217;s CD&#8217;s</a></li>
		<li id="menu-item-56814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56814"><a href="http://mymetmedia.com/category/kmetradio/punkyoureyesout/">Punk Your Eyes Out</a></li>
		<li id="menu-item-63321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63321"><a href="http://mymetmedia.com/category/kmetradio/therewind/">The Rewind</a></li>
		<li id="menu-item-62072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62072"><a href="http://mymetmedia.com/category/kmetradio/themorningsportsshow/">The Sports Morning Show</a></li>
	</ul>
</li>
	<li id="menu-item-41167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41167"><a href="http://mymetmedia.com/broadcastingschedule/">Broadcasting Schedule</a></li>
	<li id="menu-item-44094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44094"><a href="https://soundcloud.com/metradiodenver">Podcasts</a></li>
</ul>
</li>
<li id="menu-item-52690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-52690"><a href="http://mymetmedia.com/met-media-tv/">Met TV</a>
<ul class="sub-menu">
	<li id="menu-item-42322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42322"><a href="http://mymetmedia.com/category/themetreport/">Met Report</a>
	<ul class="sub-menu">
		<li id="menu-item-42583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42583"><a href="http://mymetmedia.com/category/metreportfullshows">Full Shows</a></li>
		<li id="menu-item-41282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41282"><a href="http://www.youtube.com/TheMetReport">Our YouTube Channel</a></li>
		<li id="menu-item-41286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41286"><a href="http://facebook.com/TheMetReport">Like Met Report on Facebook</a></li>
		<li id="menu-item-41285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41285"><a href="http://twitter.com/TheMetReport">Follow Met Report on Twitter</a></li>
		<li id="menu-item-42584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42584"><a href="http://mymetmedia.com/category/metreportschoolnews">School News</a></li>
		<li id="menu-item-42585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42585"><a href="http://mymetmedia.com/category/metreportnationalnews">National News</a></li>
		<li id="menu-item-42586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42586"><a href="http://mymetmedia.com/category/metreportsports">Sports</a></li>
		<li id="menu-item-43824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43824"><a href="http://mymetmedia.com/category/entertainmet">EntertainMET</a></li>
		<li id="menu-item-42588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42588"><a href="http://mymetmedia.com/category/metreportweather">Weather</a></li>
	</ul>
</li>
	<li id="menu-item-42580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42580"><a href="http://mymetmedia.com/category/noticierotvmet/">Noticiero TVMet</a>
	<ul class="sub-menu">
		<li id="menu-item-42577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42577"><a href="https://www.youtube.com/channel/UC6O15AoOBjKvxK9IeU4eFrw">Our YouTube Channel!</a></li>
		<li id="menu-item-42578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42578"><a href="https://www.facebook.com/NoticieroTVMET">Like Noticiero TVMet on Facebook!</a></li>
		<li id="menu-item-42579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42579"><a href="https://twitter.com/NTvMet">Follow Noticiero TVMet on Twitter!</a></li>
	</ul>
</li>
	<li id="menu-item-62374" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62374"><a href="http://mymetmedia.com/category/themetreport/daytimeduo/">Daytime Duo</a></li>
	<li id="menu-item-57584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57584"><a href="http://mymetmedia.com/category/themetreport/msudenverlaughs/">MSU Denver Laughs</a></li>
	<li id="menu-item-58495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58495"><a href="http://mymetmedia.com/category/themetreport/studentcorner/">Student Corner</a>
	<ul class="sub-menu">
		<li id="menu-item-62379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62379"><a href="http://mymetmedia.com/category/themetreport/studentcorner/studentsthoughts/">This Students Thoughts</a></li>
		<li id="menu-item-62378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62378"><a href="http://mymetmedia.com/category/themetreport/studentcorner/roadrunnerson/">Roadrunners On</a></li>
		<li id="menu-item-62377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62377"><a href="http://mymetmedia.com/category/themetreport/studentcorner/interviews-studentcorner/">Interviews</a></li>
	</ul>
</li>
	<li id="menu-item-56439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56439"><a href="http://mymetmedia.com/category/themetreport/thenightlymet/">The Nightly Met</a>
	<ul class="sub-menu">
		<li id="menu-item-62376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62376"><a href="http://mymetmedia.com/category/themetreport/thenightlymet/musicalperformances/">Musicals Performances</a></li>
		<li id="menu-item-62375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62375"><a href="http://mymetmedia.com/category/themetreport/thenightlymet/interviews/">Interviews</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-44257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-44257"><a href="http://mymetmedia.com/category/metrosphere">Metrosphere</a>
<ul class="sub-menu">
	<li id="menu-item-56552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56552"><a href="http://mymetmedia.com/category/metrosphere/magazine/">Magazine</a>
	<ul class="sub-menu">
		<li id="menu-item-56555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56555"><a href="http://mymetmedia.com/category/metrosphere/magazine/metro/">Metro</a></li>
		<li id="menu-item-56554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56554"><a href="http://mymetmedia.com/category/metrosphere/magazine/intersection/">Intersection</a></li>
		<li id="menu-item-56553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56553"><a href="http://mymetmedia.com/category/metrosphere/magazine/imbue/">Imbue</a></li>
		<li id="menu-item-56558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56558"><a href="http://mymetmedia.com/category/metrosphere/magazine/technosphere-magazine/">Technosphere</a></li>
		<li id="menu-item-56559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56559"><a href="http://mymetmedia.com/category/metrosphere/magazine/threads/">Threads</a></li>
	</ul>
</li>
	<li id="menu-item-42468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42468"><a href="http://mymetmedia.com/category/metrosphere/">Blog</a>
	<ul class="sub-menu">
		<li id="menu-item-56504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56504"><a href="http://mymetmedia.com/category/metrosphere/blog/adarknesswithin/">A Darkness Within</a></li>
		<li id="menu-item-56505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56505"><a href="http://mymetmedia.com/category/metrosphere/blog/ani-lytics/">Ani-lytics</a></li>
		<li id="menu-item-62641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62641"><a href="http://mymetmedia.com/category/metrosphere/catwalkconfessional/">Catwalk Confessional</a></li>
		<li id="menu-item-62681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62681"><a href="http://mymetmedia.com/category/metrosphere/comicmom/">Comic Mom</a></li>
		<li id="menu-item-62642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62642"><a href="http://mymetmedia.com/category/metrosphere/heelsnfeels/">Heels ’n’ Feels</a></li>
		<li id="menu-item-56506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56506"><a href="http://mymetmedia.com/category/metrosphere/blog/ladylumpsday/">Lady Lumps Day</a></li>
		<li id="menu-item-56507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56507"><a href="http://mymetmedia.com/category/metrosphere/blog/ledtonow/">Led to Now</a></li>
		<li id="menu-item-56508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56508"><a href="http://mymetmedia.com/category/metrosphere/blog/oldguy/">Old Guy</a></li>
		<li id="menu-item-56509" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56509"><a href="http://mymetmedia.com/category/metrosphere/blog/talesfromthetivoli/">Tales from the Tivoli</a></li>
		<li id="menu-item-56510" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56510"><a href="http://mymetmedia.com/category/metrosphere/blog/talesofsummercamp/">Tales of Summer Camp</a></li>
		<li id="menu-item-56512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56512"><a href="http://mymetmedia.com/category/metrosphere/blog/thejoyofcinema/">The Joy of Cinema</a></li>
		<li id="menu-item-56513" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56513"><a href="http://mymetmedia.com/category/metrosphere/blog/writerleidoscope/">Writerleidoscope</a></li>
	</ul>
</li>
	<li id="menu-item-56557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56557"><a href="http://mymetmedia.com/category/metrosphere/magazine/currentissue/">Digital Issue</a></li>
	<li id="menu-item-56514" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56514"><a href="http://mymetmedia.com/category/metrosphere/metrosphereradio/">Radio</a>
	<ul class="sub-menu">
		<li id="menu-item-62541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62541"><a href="http://mymetmedia.com/category/metrosphere/lakeclarity/">Lake Clarity</a></li>
		<li id="menu-item-62561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62561"><a href="http://mymetmedia.com/category/metrosphere/metrosphereradio/">Metrosphere Radio</a></li>
	</ul>
</li>
	<li id="menu-item-42266" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-42266"><a href="http://mymetmedia.com/metrosphere2/art/">Art</a>
	<ul class="sub-menu">
		<li id="menu-item-42270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42270"><a href="http://mymetmedia.com/category/metrosphere/2-d/">2-D</a></li>
		<li id="menu-item-43894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43894"><a href="http://mymetmedia.com/category/metrosphere/3-d/">3-D</a></li>
		<li id="menu-item-58041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58041"><a href="http://mymetmedia.com/category/metrosphere/art-metrosphere/communicationdesign/">Communication Design</a></li>
		<li id="menu-item-58036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58036"><a href="http://mymetmedia.com/category/metrosphere/art-metrosphere/film/">Film</a></li>
		<li id="menu-item-58037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58037"><a href="http://mymetmedia.com/category/metrosphere/art-metrosphere/jewelry/">Jewelry</a></li>
		<li id="menu-item-58038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58038"><a href="http://mymetmedia.com/category/metrosphere/art-metrosphere/music-art-metrosphere/">Music</a></li>
		<li id="menu-item-58039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58039"><a href="http://mymetmedia.com/category/video-3/">Video</a></li>
	</ul>
</li>
	<li id="menu-item-42853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42853"><a href="http://mymetmedia.com/category/metrosphere/literature/">Literature</a>
	<ul class="sub-menu">
		<li id="menu-item-42854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42854"><a href="http://mymetmedia.com/category/metrosphere/literature/drama-literature/">Drama</a></li>
		<li id="menu-item-58042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58042"><a href="http://mymetmedia.com/category/metrosphere/literature/fiction/">Fiction</a></li>
		<li id="menu-item-58043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58043"><a href="http://mymetmedia.com/category/metrosphere/literature/nonfiction/">Nonfiction</a></li>
		<li id="menu-item-42855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42855"><a href="http://mymetmedia.com/category/metrosphere/literature/poetry-literature/">Poetry</a></li>
	</ul>
</li>
	<li id="menu-item-40348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-40348"><a href="http://mymetmedia.com/metrosphere2/submit-work/">Submit Your Work</a>
	<ul class="sub-menu">
		<li id="menu-item-40349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40349"><a href="http://mymetmedia.com/metrosphere2/submit-work/guidelines/">Guidelines</a></li>
		<li id="menu-item-40350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40350"><a href="http://mymetmedia.com/metrosphere2/submit-work/selection-judging/">Selection and Judging</a></li>
	</ul>
</li>
	<li id="menu-item-62344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62344"><a href="http://mymetmedia.com/metrosphere2/about-us/">About Us</a></li>
</ul>
</li>
							</ul>
						</nav>
						<div class="clearfix"></div>
						
						<section id="bootstartCarousel" class="carousel slide">
							  <div class="carousel-inner">
							  
																<div class="item active">
									<h2><a href="http://mymetmedia.com/news/lc-ep-3-credits/" rel="bookmark" title="Permalink to LC Ep 3: Credits" >Highlights: LC Ep 3: Credits</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/themetreport/paris-in-denver/" rel="bookmark" title="Permalink to Paris in Denver" >Highlights: Paris in Denver</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/the-metropolitan/defining-scrappy-journey-success/" rel="bookmark" title="Permalink to Defining “scrappy”: Antonio Ledesma&#8217;s journey to success" >Highlights: Defining “scrappy”: Antonio Ledesma&#8217;s journey to success</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/the-metropolitan/going-flow-water-careers-display/" rel="bookmark" title="Permalink to Going with the flow: Water careers on display" >Highlights: Going with the flow: Water careers on display</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/news/podcast-maj-gen-jeffrey-snow/" rel="bookmark" title="Permalink to Podcast: U.S. Army Maj. Gen. Jeffrey Snow Interview (3/8/17)" >Highlights: Podcast: U.S. Army Maj. Gen. Jeffrey Snow Interview (3/8/17)</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/news/the-nance-at-the-edge/" rel="bookmark" title="Permalink to &#8216;The Nance&#8217; at the Edge" >Highlights: &#8216;The Nance&#8217; at the Edge</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/the-metropolitan/reefbuilders-bring-diverse-ecosystems-take-home/" rel="bookmark" title="Permalink to Reefbuilders bring diverse ecosystems to take home" >Highlights: Reefbuilders bring diverse ecosystems to take home</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/the-metropolitan/examination-of-empathy-through-poetic-expression/" rel="bookmark" title="Permalink to The 25 annual Bridge Speaker event examines empathy through poetic expression" >Highlights: The 25 annual Bridge Speaker event examines empathy through poetic expression</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/news/met-report-live-2/" rel="bookmark" title="Permalink to The Met Report Live" >Highlights: The Met Report Live</a></h2>
								</div>
								
																<div class="item ">
									<h2><a href="http://mymetmedia.com/the-metropolitan/love-your-body-workshop-educates-body-love-when-the-world-tells-you-to-hate-it/" rel="bookmark" title="Permalink to Love Your Body workshop educates body love when the world tells you to hate it" >Highlights: Love Your Body workshop educates body love when the world tells you to hate it</a></h2>
								</div>
								
															  </div>
							  <a class="left carousel-control" href="#bootstartCarousel" data-slide="prev">&lt;</a>
							  <a class="right carousel-control" href="#bootstartCarousel" data-slide="next">&gt;</a>
						</section><!-- /.carousel -->
						<div class="clearfix"></div>
					</header><!-- header -->
<div class="post-container">
			
		<!-- Post-Lead -->
		<section class="post-lead">
			<h1 class="post-title">Kid Cudi: Passion, Pain &#038; Demon Slaying</h1>
			<p class="single_postmeta">
				<span>By <a href="http://mymetmedia.com/author/aherre38/">Andrea Herrera</a> on March 11, 2017</span>
				<span>
					<a rel="nofollow" href="#" id="increase-font" class="fontsize-button fontSizeMinus" title="Decrease font size"><i class="icon-minus-sign"></i></a>
					<a rel="nofollow" href="#" id="decrease-font" class="fontsize-button fontSizePlus" title="Increase font size"><i class="icon-plus-sign"></i></a>
					<a rel="nofollow" href="javascript:window.print()" class="print-this-page" title="Print this post"><i class="icon-print"></i></a>
					<a class="email-this-page" href="mailto:?subject=My%20Met%20Media%20%3A%20Kid%20Cudi%3A%20Passion%2C%20Pain%20%26amp%3B%20Demon%20Slaying&amp;body=I%20recommend%20this%20page%3A%20Kid%20Cudi%3A%20Passion%2C%20Pain%20%26amp%3B%20Demon%20Slaying.%0AYou%20can%20read%20it%20on%3A%20http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F" title="Send by email : Kid Cudi: Passion, Pain &amp; Demon Slaying"><i class="icon-envelope-alt"></i></a>				</span>
			</p>
			
										
		</section>

		<section class="postbody-wrapper postlayout-default">

		
	<div class="post-column pull-left">
		<article class="entry post-63516 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-music category-the-metropolitan tag-artist tag-hip-hop tag-kid-cudi tag-music tag-rock entity-metropolitan-entity last_archivepost">		
				<p>As a die-hard Kid Cudi fan, I have always admired how unique and distinguished his style can be. His past albums have shown his audience how he can easily transform himself musically in any way he wants. Early in his career, Cudi was known as a hip-hop artist. As the time passed, this Top 5 Billboard sensation developed his skills and showed the world he could do more than simply rap. He soon decided to become a singer, songwriter, record producer, guitarist, music video director and film composer. Since 2008, Cudi has released several albums and in between those years quite a few mixtapes.</p>
<div id="attachment_63531" style="width: 600px" class="wp-caption alignright"><img data-attachment-id="63531" data-permalink="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/attachment/kid-cudi-performing-at-the-2010-sasquach-music-festival-photo-from-flickr/" data-orig-file="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg" data-orig-size="4890,3260" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;Kid Cudi performing at the 2010 Sasquach! music festival. Photo from Flickr.&quot;,&quot;created_timestamp&quot;:&quot;1275219216&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;135&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;Kid Cudi performing at the 2010 Sasquach! music festival. Photo from Flickr.&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Kid Cudi performing at the 2010 Sasquach! music festival. Photo from Flickr." data-image-description="" data-medium-file="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg" data-large-file="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg" class=" wp-image-63531" src="http://mymetmedia.com/wp-content/uploads/2017/03/F_030817_KidCudi_001.jpg" alt="Kid Cudi" width="590" height="393" /><p class="wp-caption-text">Kid Cudi performing at the 2010 Sasquach! music festival. Photo from Flickr.</p></div>
<p>In 2016, he released the album “<a href="https://www.amazon.com/Passion-Pain-Demon-Slayin-Cudi/dp/B01N9K905K">Passion, Pain &amp; Demon Slaying</a>.” The album was soon a trending on social media. It was recognized for its high number of plays within the first week. Cudi’s album sold 24,000 copies in a week and was named 11 in the Billboard Top 200. It’s safe to say this album caught the attention of listeners just like me. The first time I heard this album, I was sitting at home and it was a moment of love. I instantly knew he had done it again and the feeling was amazing. From “Frequency” all the way down to “Surfin,” the beats make you feel a special way. Whether you’re cruising around in your car, relax or getting “hype” with your friends and following that Coloradan trend of “smoking it up,” Cudi delivers.</p>
<p>I went with the first option and decided to go for a late night ride to a friend’s house. We sat in the car listening to each lyric, each beat and part of the song. Throughout the whole album Cudi maintains a unique and steady musical beat, making that his signature. However, the lyrics are what truly make a difference when listening to the album. Each song has a different meaning behind it, which explains the different parts of his life and his journey and Cudi switches it up 19 times throughout the album.</p>
<p>Going from a sort of alternative rock to a straight hip hop/indie album is one of the many talents this artist is able to share with his fans. The variety of artists who are featured on this album also plays a huge role in the amount of diversity that is shown within each songs.</p>
<p>Truly this album is one, if not the one, of my top 5 favorite albums ever. I would recommend it to anyone who ever wants to have a chill night, day or simply wants to be in a great mood throughout the week. This album will surely do that for you. Keeping it different and real is something you can always expect from the Great Cudi the Kid.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-63516" class="share-facebook sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-63516" class="share-twitter sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-63516" class="share-linkedin sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>				
				
<div id="comments">
	
			<h3 id="comments-title">
			One Response to &#34;<span>Kid Cudi: Passion, Pain &#038; Demon Slaying</span>&#34;		</h3>

	
	<ol class="commentlist">
			<li class="comment even thread-even depth-1" id="li-comment-28753">

		<div class="comment-inner" id="comment-28753">
		
			<div class="comment-top">
				<div class="comment-avatar">
					<img alt='' src='http://1.gravatar.com/avatar/1df5655b3b73f09d07824f0daa0754dc?s=50&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/1df5655b3b73f09d07824f0daa0754dc?s=100&amp;d=mm&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />				</div> 
				<span class="comment-author">
					<i class="icon-user"></i> 
					<cite class="fn">Kyle ketcher</cite> 				</span>
				<span class="comment-date-link">
					<i class="icon-calendar-empty"></i>&nbsp;March 15, 2017 at 9:50 am				</span>
			</div>				
			
						
			<p>He didn&#8217;t have Chip on it. So as a cudder fan I&#8217;m upset that he didn&#8217;t show Cleveland</p>
			
			<a rel='nofollow' class='comment-reply-link' href='http://mymetmedia.com/the-metropolitan/kid-cudi-passion-pain-demon-slaying/?replytocom=28753#respond' onclick='return addComment.moveForm( "comment-28753", "28753", "respond", "63516" )' aria-label='Reply to Kyle ketcher'>Reply</a>			
		</div><!-- comment-inner  -->

	</li><!-- #comment-## -->
	</ol>

	
	
	
		
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-metropolitan/kid-cudi-passion-pain-demon-slaying/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=72973898&#038;postid=63516&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.7.1&#038;sig=2e2a1bd1fd3b1a5e6d31453cf66c189fce1ec311#parent=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
	
</div><!-- #comments -->		</article>
	</div><!-- post column -->
		
	<aside id="sidebar" class="sidebar pull-right">
		                <div class="sidebarbanner 11">
                  <section id="adsanity-random-6" class="widget adsanity-random"><div class="widgetinner"><div id="ad-57929" class="ad-300x250 column-1">
			<a rel="nofollow" href="http://mymetmedia.com/ads/timbuk2/" target="_blank"><img width="300" height="250" src="http://mymetmedia.com/wp-content/uploads/2016/09/20160101-tuck-activation-denver-300x250.jpg" class="attachment-full size-full wp-post-image" alt="" data-attachment-id="57930" data-permalink="http://mymetmedia.com/ads/timbuk2/attachment/20160101-tuck-activation-denver-300x250/" data-orig-file="http://mymetmedia.com/wp-content/uploads/2016/09/20160101-tuck-activation-denver-300x250.jpg" data-orig-size="300,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="timbuk2" data-image-description="" data-medium-file="http://mymetmedia.com/wp-content/uploads/2016/09/20160101-tuck-activation-denver-300x250.jpg" data-large-file="http://mymetmedia.com/wp-content/uploads/2016/09/20160101-tuck-activation-denver-300x250.jpg" /></a>
	</div><div class="clear clearfix clearboth"></div></div></section>
                </div>
              						
<section id="search-7" class="widget widget_search"><div class="widgetinner"><h3 class="widgettitle">Search </h3>
<form class="searchform" action="http://mymetmedia.com/">
	<fieldset>
		<input type="text" id="s" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
		<input type="image" class="submitsearch" src="http://mymetmedia.com/wp-content/themes/_stylebook/framework/images/clear.png" alt="Search in site..." value="" /> 
	</fieldset>
</form></div></section>
		<section id="recent-posts-7" class="widget widget_recent_entries"><div class="widgetinner">		<h3 class="widgettitle">Latest Posts </h3>
		<ul>
					<li>
				<a href="http://mymetmedia.com/metradio/japanese-house-sells-globe-hall-denver/">The Japanese House Sells Out The Globe Hall In Denver!</a>
							<span class="post-date">March 15, 2017</span>
						</li>
					<li>
				<a href="http://mymetmedia.com/metrosphere/catwalkconfessional/hclf-vegan-diet/">My Fruit Diet Drove Me Bananas</a>
							<span class="post-date">March 14, 2017</span>
						</li>
					<li>
				<a href="http://mymetmedia.com/metrosphere/heelsnfeels/stick-shift-car-ruined-driving/">My Stick Shift Car Ruined Driving</a>
							<span class="post-date">March 13, 2017</span>
						</li>
					<li>
				<a href="http://mymetmedia.com/sports/roadrunners-baseball-weekend-recap-mar12/">Baseball Weekend Recap: Roadrunners Take Three of Four from Cowboys</a>
							<span class="post-date">March 12, 2017</span>
						</li>
					<li>
				<a href="http://mymetmedia.com/the-metropolitan/seasoned-coach-athlete-chosen-lead/">Seasoned coach, athlete chosen to lead</a>
							<span class="post-date">March 12, 2017</span>
						</li>
				</ul>
		</div></section>
		

               <div class="sidebarbanner bottomad">
                                  </div>
              	</aside>
	<div class="clearfix"></div>
</section><!-- postlayout-default -->
	</div>
	
			</div><!-- Sitebody -->
		</div> <!-- span12 -->
	</div><!-- .row -->
</div><!-- .container -->

	<section class="container-fluid follow_us">
		<div class="container">
			<div class="row">
				<div class="span2 first-followus-div">
											<a href="http://www.facebook.com/metmedia" rel="nofollow">
							<i class="icon-facebook icon-2x pull-left"></i>
							<span class="follow_us_linktitle">Facebook</span>
							<span class="follow_us_linkdesc">Friend Us</span>
						</a>
									</div>
				<div class="span2">
											<a href="https://twitter.com/MyMetMedia" rel="nofollow">
							<i class="icon-twitter icon-2x pull-left"></i>
							<span class="follow_us_linktitle">Twitter</span>
							<span class="follow_us_linkdesc">Follow Us</span>
						</a>
									</div>
				<div class="span2 third-followus-div">
									</div>
				<div class="span2 text-align-right">
									</div>
				<div class="span2 text-align-right">
									</div>
				<div class="span2 text-align-right last-followus-div">
					<a href="http://mymetmedia.com/feed/" rel="nofollow">
						<i class="icon-rss icon-2x pull-right"></i>
						<span class="follow_us_linktitle">RSS</span>
						<span class="follow_us_linkdesc">Site Feed</span>
					</a>
				</div>
				<div class="clearfix"></div>
			</div><!-- /row --> 
		</div><!-- /container --> 
	</section><!-- /follow_us -->
	
<footer class="container-fluid footer">
	<div class="container">

		<div class="row">
			<div class="span4">
				<section id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><div class="widgetinner"><h3 class="widgettitle">Social</h3>
<ul><li></li></ul></div></section>
			</div>
			
			<div class="span4">
							</div>
			
			<div class="span4">
							</div>
		</div>
	</div>
</footer>

<section class="container-fluid footer_meta">
	<div class="container">
		<div class="row">
			<div class="span6 footer-left-side">
							</div><!-- #site-info -->
						
			<div class="span6 footer-right-side">
				Copyright 2016. All Rights Reserved. Metropolitan State University of Denver Met Media				
								 
				
				
				
<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'http://mymetmedia.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
                    soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    
		
		<div id="fb-root"></div>
		<script type='text/javascript'>
		<!--
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		// -->
		</script>
			
	<script>
    jQuery(document).ready(function () {
		jQuery.post('http://mymetmedia.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/mymetmedia.com\/the-metropolitan\/kid-cudi-passion-pain-demon-slaying\/":63516};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/the-metropolitan/kid-cudi-passion-pain-demon-slaying/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://mymetmedia.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<link rel='stylesheet' id='font-awesome-ie7-css'  href='http://mymetmedia.com/wp-content/themes/_stylebook/framework/font-awesome/css/font-awesome-ie7.min.css?ver=99e1b4f6d34c45e6257354c89fd35708' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://mymetmedia.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='genericons-css'  href='http://mymetmedia.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/comment-reply.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201711'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/themes/mymetmedia/inc/js/head.js?ver=1489699087'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-includes/js/wp-embed.min.js?ver=99e1b4f6d34c45e6257354c89fd35708'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/mymetmedia.com\/wp-admin\/admin-ajax.php","nonce":"565a6960b2","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/mymetmedia.com\/wp-login.php?redirect_to=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mymetmedia.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=72973898&postid=63516&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=2e2a1bd1fd3b1a5e6d31453cf66c189fce1ec311#parent=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=72973898&postid=63516&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=2e2a1bd1fd3b1a5e6d31453cf66c189fce1ec311#parent=http%3A%2F%2Fmymetmedia.com%2Fthe-metropolitan%2Fkid-cudi-passion-pain-demon-slaying%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201711.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'72973898',post:'63516',tz:'-6',srv:'mymetmedia.com'} ]);
	_stq.push([ 'clickTrackerInit', '72973898', '63516' ]);
</script>
			</div> <!-- #footer-right-side -->
		</div>
	</div>
</section>

</body>
</html>